Respuesta a: Eclipse 4.2.2

#7416

Anónimo
Inactivo

Vale, ya he encontrado la solución. Tras varias horas buscando en foros de la comunidad de Eclipse en ingles, encontre el problema aunque no entiendo el proceso porque no tengo conocimientos sobre esto. Pongo la solución en español por si alguien tiene el mismo problema algún dia. Algunas palabras las pongo en ingles porque mi Eclipse está en ingles y no se exactamente el equivalente al español.

Si has cambiado de JDK y has tenido que importar un proyecto, y te aparecen todas las lineas de codigo en rojo, tienes que asegurarte de que el Path Class de tu protecto es correcto:

1-<span class=”MsgBodyText”>Click derecho en el proyecto, elige Build Path-> Configure Build Path
</span>

Captura de pantalla—> https://ibb.co/hgN5Bw

2-Haz clicl en Libraries tab.

https://ibb.co/hH1RJb

3-Busca el JRE System Library [la version del JRE que tienes instalado]

Deberia aparecerte la libreria como en la ultima captura de pantalla que he compartido. Si no aparece ninguna libreria o simplemente aparece como en la mia pero con una cruz roja o alguna marca roja simbolizando “error” es porque Eclipse no encuentra el JRE Library original. Ahora hay que corregir eso:

4- Si aparece una libreria con una cruz o marca roja, elígela y dale a eliminar.

5- Haz click en Add Library o Añadir Libreria…

6-Haz click en JRE System Library

7- Next

8- O tambien permite que use el valor predeterminado de la estación de trabajo(workstation). Puede que tambien tengas aque hacer otros arreglos como encontrar otro JDK que hayas descargado en tu host.

9- Haz click en Finish

 

Yo no tuve que hacer ningún arreglo, le di a next, seleccione el Workstation como default y le di a finish, solucionandose el problema. Espero haber sido claro, dejo el enlace de la pagina del foro en la que econtre la solucion:

https://www.eclipse.org/forums/index.php/t/628433/