Home Foros Foro dudas Foro de HTML SOS AYUDA URGENTE Respuesta a: SOS AYUDA URGENTE

Respuesta a: SOS AYUDA URGENTE

Home Foros Foro dudas Foro de HTML SOS AYUDA URGENTE Respuesta a: SOS AYUDA URGENTE

#6443

STE ES EL ERROR QUE DA
Ingresa CI
> 3825
Ingresa Nombre
> cesar
cual es su problema
> cardiovascular
Lin 12 (inst 1): ERROR 303: Subindice (0) fuera de rango
(1…6)

EL ENUNCIADO
Un médico clasifica sus pacientes en tres tipos según sea el problema
que presenta y ordena radiografías de acuerdo a la siguiente etapa:

Tipo Problema Numero de
Radiografías
C Cardiovascular 1
R Respiratorio 2
D Todos los demás 3

El médico cobra 15.000 BsF por consultas y cada radiografía cuesta
10.000 BsF. Si se conoce el número de la cédula de identidad del
paciente, su nombre y el problema que padece. Mostrar la siguiente
información:

o Cédula de identidad
o Nombre
o Tipo de problema
o Número de radiografías
o Cantidad a pagar por honorarios
o Cantidad a pagar por radiografías
o Cantidad total a pagar por honorarios y radiografías
o Cantidad total de pacientes con problema Cardiovascular
o Cantidad total de pacientes con problema Respiratorio

Algoritmo trabajo
Definir arreglo Como Numerica
Dimension arreglo[6]
Definir problema Como Caracter
Definir numero,num1,suma,radiografia Como Entero
Escribir ‘Ingresa CI’
Leer CI
Escribir ‘Ingresa Nombre’
Leer Nombre
Escribir ‘cual es su problema’
Leer problema
arreglo[num1] <- radiografia
arreglo[num2] <- 2
arreglo[num3] <- 3
arreglo[num4] <- consultas
arreglo[num5] <- cardiovascular
arreglo[num6] <- respiratorio
Para i<-1 Hasta 6 Hacer
Leer arreglo[6]
FinPara
Para i<-1 Hasta 6 Hacer
Escribir arreglo[4]
FinPara
consultas <- 10000
radiografia <- 15000
Para i<-0 Hasta 6 Hacer
Leer arreglo[num1]
FinPara
Para i<-0 Hasta 1 Hacer
Escribir D,debera,pagar,1*radiografia+1*consulta
FinPara
suma <- cardiovascular+resp
suma2 <- radiografia+consulta
Escribir ‘El total a pagar es ‘,suma2
Escribir ‘la Cantidad de pacientes con problema cardiovascular es ‘,suma
Escribir ‘la Cantidad de pacientes con problema respiratorio es ‘,s
suma <- cardiovascular+resp
suma2 <- radiografia+consulta
Escribir ‘El total a pagar es ‘,suma2
Escribir ‘la Cantidad de pacientes con problema cardiovascular es ‘,suma
Escribir ‘la Cantidad de pacientes con problema respiratorio es ‘,suma
FinAlgoritmo